SoA unter Windows 10

      SoA unter Windows 10

      Hallo Zusammen :)
      ​Super, dass hier noch Leuts sind, die SoA genausko klasse finden wie ich :)
      ​Habe es vor 2 Tagen auch nochmal hervorgekramt und würds es so gerne nochmal durchzocken, weils das erste RPG war, das ich je gespielt habe.
      ​Leider treten bei mir auch die Slowdowns , Lags und Zeigerruckler bei den NPC-Dialogtexten auf. Daher habe ich auch schon versucht, die Probleme mit dem Fix von Voldemort zu beheben (für Windows Vista/7/8).
      ​Den Zip Ordner runtergeladen, Dateien entpackt und in den SoA Hauptordner kopiert - leider klappt es nicht, die Probs bestehen weiterhin (habe das auch zur Sicherheit auch in den entsprechenden Thread nochmal geschrieben)
      ​Mein Rechner läuft mit Windows 10, die Graka ist eine Nvidia 960. Vielleicht kann mir jemand weiterhelfen, würde mich sooooo freuen....
      Ich vermute, dass es an Windows 10 liegt. Hab nämlich diegleiche Grafikkarte und keine Ruckler. Lediglich die Mausflackerer sind auch bei Dialogen da (also allgemein wenn das Interface geöffnet ist). Probier mal:
      Schatten ausmachen
      oder evtl:
      Siege.ini öffnen und interval=15 im [Settings]-Bereich reinschreiben. Das nämlich beschleunigt das Spiel allgemein.
      Der zweiten Post extra war nicht nötig bei Windows Vista/7/8 Fix bei Grafikproblemen.

      Wo ich bin klappt nichts,...
      aber ich kann ja nicht überall sein.
      Hallo zusammen,

      ich habe es mit den genannten Tipps recht schnell geschafft SoA unter Windows 10 zum Laufen zu bringen, hier nochmal kurz zusammengefasst:
      • Alle SoA-Kapitel installiert (mein Gerät hat leider kein eignes Laufwerk, deshalb via alten Laptop direkt auf USB-Stick installiert und dann auf die Festplatte kopiert)
      • aktuellen SoAmigos-Patch (0.7) installiert
      • voldemorts Fix benutzt (Windows Vista/7/8 Fix bei Grafikproblemen/Slowdowns/Lags)
      • unter Eigenschaften von "DTMain1.exe" bei Kompatibilität folgende Einstellungen vorgenommen:
        • "[...]ausführen für:" Windows XP (Service Pack 2)
        • Modus mit reduzierten Farben: "8-Bit-Farben (256)"
        • "In Bildschirmauflösung 640 x 480 ausführen"
        • als Administrator ausführen
      • ​Schatten ausgestellt
      Mit den genannten Schritten läuft SoA butterweich, davor war es quasi unspielbar. Natürlich kann es sein, dass auch andere Einstellungen funktionieren, ich habe recht willkürlich die Sachen ausgewählt und bin mit dem Ergebnis sehr zufrieden.
      In diesem Sinne: Viel Spaß! Es läuft noch immer...

      ​Edit: Der Vollständigkeit halber: Es kommt gelegentlich doch zu Abstürzen, v.a. wenn ich zwischen verschiedenen "Dorf"-Maps wechsle. Meist geht's gut, für den Fall der Fälle speicher ich aber einfach kurz vorher. Manchmal kommt dann eben eine Fehlermeldung und beim Bestätigen wird das Spiel geschlossen, lädt aber zum Glück alles sehr schnell wieder. Ah und lustigerweise wandert unter den Feuerball-Spells ein grüner Schatten, auch das stört aber nicht wirklich.
      Ein Baum hat Äste,
      das ist das Beste,
      denn wäre er kahl,
      dann wärs ja ein Pfahl!

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Mithrandir“ ()

      ok, vielleicht kann mir ja jemand helfen:
      Jetzt geht's doch nicht mehr. -.-
      Beim Versuch im 2. Kapitel zum ersten Mal die Krypta zu betreten beendet sich das Spiel schlagartig. Es erscheint noch der Ladebildschirm und sobald es fertig geladen ist schließt sich das Fenster komplett. Ich benutze die oben genannten Einstellung und habe noch ein wenig im Kompatibilitäsmodus von W10 herumgespielt, ohne Erfolg. Hat jemand noch Vorschläge?
      Bei anderen Levelübergängen bin ich gelegentlich auch mal rausgeflogen, das klappte dann aber immer nach ein paar Versuchen (verrückterweise hatte ich den Eindruck, dass ich beim Wechsel von Dorf zu Dorf manchmal an einer anderen Stelle die Karte wechseln musste damit es klappt - macht das Sinn?)
      Bin für alle Vorschläge offen ^^

      ​Edit: Habe jetzt auch die Erweiterung installiert, den Cache deaktiviert und es ein paar Mal versucht...
      ​Siege.log:
      Spoiler anzeigen
      ​DTMain1.exe
      32 = Size of 'MemoryStatus' record
      5% memory in use
      267862016 Total Physical Memory in bytes
      235843584 Available Physical Memory in bytes
      1879617536 Total Bytes of Paging File
      1860378624 Available bytes in paging file
      2143289344 User Bytes of Address space
      1939533824 Available User bytes of address space
      ===== End Of Header =====
      19:14:00 00000000: Start Siege
      19:14:00 00000000: Set Bounds
      19:14:00 00000000: Mode=DX
      19:14:00 00000000: Read Settings
      19:14:00 00000000: Item DB=ArtLib\Resources\Database\Items.DB
      19:14:00 00000000: XRef DB=ArtLib\Resources\Database\xref.db
      19:14:00 00000000: Titles DB=ArtLib\Resources\Database\Title.db
      19:14:00 00000000: ArtPath=ArtLib\Resources\
      19:14:00 00000000: TilePath=ArtLib\Tiles\
      19:14:00 00000000: SoundPath=ArtLib\Resources\Audio\
      19:14:00 00000000: InterfacePath=Interface\
      19:14:00 00000000: CachePath=C:\PROGRA~2\DIGITA~1\SIEGEO~1\cache\
      19:14:00 00000000: DefaultTransition=Interface\GeneralTransition1.bmp
      19:14:00 00000000: Brightness=0
      19:14:00 00000000: Create Globals
      19:14:00 00000000: Sound enabled
      19:14:00 00000000: Initializing sound
      19:14:00 00000000: Creating sound object...
      19:14:01 00000000: MP3 Init Succeeded
      19:14:01 00000000: Music enabled
      19:14:01 00000000: Initializing music
      19:14:01 00000000: Creating music object...
      19:14:01 00000000: Sound card available
      19:14:01 00000000: Initializing event timer
      19:14:01 00000000: Interval=30
      19:14:01 00000000: ReadCache enabled
      19:14:01 00000000: WriteCache enabled
      19:14:01 00000000: UseLighting enabled
      19:14:01 00000000: Start event timer
      19:14:01 00000000: Initializing DX...
      19:14:02 00000000: DX initialization complete
      19:14:02 00000000: Using 565 Driver
      19:14:02 00000000: Loading cursor
      19:14:02 00000000: Initializing DFX...
      19:14:02 00000000: Using 565 Driver
      19:14:02 00000000: Loading resources...
      19:14:02 00000000: Loading console...
      19:14:03 00000000: Console load Complete
      19:14:03 00000000: Loading interface...
      19:14:03 00000000: Interface load Complete
      19:14:03 00000000: Loading FireSpell cast effect...
      19:14:03 00000000: Loading Frost cast effect...
      19:14:03 00000000: Loading shockblu cast effect...
      19:14:03 00000000: Loading shrapnelcast cast effect...
      19:14:03 00000000: Loading chargespell4 cast effect...
      19:14:03 00000000: Loading push cast effect...
      19:14:03 00000000: Loading healcast cast effect...
      19:14:03 00000000: Loading charge2 cast effect...
      19:14:03 00000000: Loading summoncast cast effect...
      19:14:03 00000000: Loading holdcast cast effect...
      19:14:03 00000000: Loading lichcast cast effect...
      19:14:03 00000000: Loading AuraSteelCast cast effect...
      19:14:03 00000000: Loading ManaThiefCast cast effect...
      19:14:03 00000000: Loading GreatHandCast cast effect...
      19:14:03 00000000: Loading GreatWolfCast cast effect...
      19:14:03 00000000: Loading FireCast(LVL3) cast effect...
      19:14:03 00000000: Loading Frost(LVL3) cast effect...
      19:14:03 00000000: Loading ReflectCast cast effect...
      [...]
      19:14:06 00000000: Load complete
      19:14:07 00000000: App Activate
      19:14:10 00000000: Loading saved game: QuickSave
      19:14:10 00000000: Clearing spell resources
      19:14:10 00000000: Clearing spell effect resources
      19:14:10 00000000: -----------------------------------------------------
      19:14:10 00000000: Init
      19:14:10 00000000: Loading map...
      19:14:10 00000000: Map File=C:\PROGRA~2\DIGITA~1\SIEGEO~1\maps\caves02.lvl
      19:14:10 00000000: Scene=Default Scene
      19:14:10 00000000: Reading header block
      19:14:10 00000000: Reading zone block
      19:14:10 00000000: MaxZone=0
      19:14:10 00000000: Count=0
      19:14:10 00000000: Loading cache
      19:14:10 00000000: Skipping rect resources because of cache...
      19:14:10 00000000: Skipping diamond resources because of cache...
      19:14:10 00000000: Loading object resources...
      19:14:10 00000000: Reading resource list
      19:14:11 00000000: Object resources complete
      19:14:11 00000000: Reading scene
      19:14:11 00000000: Default Scene
      19:14:11 00000000: Applying scene
      19:14:11 00000000: AmbientColor=16744576
      19:14:11 00000000: AmbientBlend=80
      19:14:11 00000000: Reading map known block
      19:14:11 00000000: Reading theme block
      19:14:11 00000000: Reading object blocks
      19:14:12 00000000: Map load complete
      19:14:12 00000000: Loading scene
      19:14:15 00000000: Creating new item
      [...]
      19:14:17 00000000: Freeing unused parts
      19:14:17 00000000: KeyFigure=Player
      19:14:17 00000000: Memory usage
      19:14:17 00000000: Map: 630000
      19:14:17 00000000: Sprites: 37516288
      19:14:17 00000000: Zone 0: 16082176
      19:14:17 00000000: Total all zones: 16082176
      19:14:17 00000000: Map item count=9091
      19:14:17 00000000: Assigning map to game environment
      19:14:17 00000000: Creating map buffer
      19:14:17 00000000: Creating work buffer
      19:14:17 00000000: MapColumns
      19:14:17 00000000: MapRows
      19:14:17 00000000: BuildRowUpdateInfo
      19:14:17 00000000: Assignment Complete
      19:14:17 00000000: Initialization complete
      19:14:17 00000000: Setting theme
      19:14:17 00000000: Running load scripts
      19:14:17 00000000: Load complete
      19:14:22 00000106: SaveGame
      19:14:22 00000106: Copy files
      19:14:22 00000106: ClearOnDemandResources
      19:14:22 00000106: Clearing spell resources
      19:14:22 00000106: Clearing spell effect resources
      19:14:22 00000106: ClearResources
      19:14:22 00000106: ReAlloc
      19:14:22 00000106: LoadMapFile
      19:14:22 00000106: -----------------------------------------------------
      19:14:22 00000106: Init
      19:14:22 00000106: Loading map...
      19:14:22 00000106: Map File=C:\PROGRA~2\DIGITA~1\SIEGEO~1\maps\crypt01.lvl
      19:14:22 00000106: Scene=Default Scene
      19:14:23 00000106: Reading header block
      19:14:23 00000106: Reading zone block
      19:14:23 00000106: MaxZone=0
      19:14:23 00000106: Count=0
      19:14:23 00000106: Loading cache
      19:14:23 00000106: Skipping rect resources because of cache...
      19:14:23 00000106: Skipping diamond resources because of cache...
      19:14:23 00000106: Loading object resources...
      19:14:23 00000106: Reading resource list
      19:14:23 00000106: Object resources complete
      19:14:23 00000106: Reading scene
      19:14:23 00000106: Default Scene
      19:14:23 00000106: Applying scene
      19:14:23 00000106: AmbientColor=14810782
      19:14:23 00000106: AmbientBlend=60
      19:14:23 00000106: Reading map known block
      19:14:23 00000106: Reading theme block
      19:14:23 00000106: Reading object blocks
      19:14:23 00000106: Map load complete
      19:14:23 00000106: Loading scene
      19:14:24 00000106: Freeing unused parts
      19:14:24 00000106: KeyFigure=Player
      19:14:24 00000106: Memory usage
      19:14:24 00000106: Map: 403200
      19:14:24 00000106: Sprites: 26212791
      19:14:24 00000106: Zone 0: 8033280
      19:14:24 00000106: Zone 1: 298496
      19:14:24 00000106: Total all zones: 8331776
      19:14:24 00000106: Map item count=10289
      19:14:24 00000106: Assigning map to game environment
      19:14:24 00000106: Creating map buffer
      19:14:24 00000106: Creating work buffer
      19:14:24 00000106: MapColumns
      19:14:24 00000106: MapRows
      19:14:24 00000106: BuildRowUpdateInfo
      19:14:24 00000106: Assignment Complete
      19:14:24 00000106: Initialization complete
      19:14:24 00000106: Setting theme
      19:14:24 00000106: Running load scripts
      19:14:24 00000106: Load complete
      19:14:24 00000106: Saving "Start of Level"
      19:14:24 00000106: Program Save
      19:14:24 00000106: *** Authorization failed 1
      19:14:24 00000106: Map could not be loaded 0
      19:14:24 00000106: Freeing resources
      19:14:24 00000106: Freeing globals
      19:14:24 00000106: Freeing dialogs
      19:14:24 00000106: Freeing spell resources
      19:14:24 00000106: Freeing spell effect resources
      19:14:24 00000106: Freeing console
      19:14:24 00000106: Terminating DFX
      19:14:24 00000106: Terminating DX...
      19:14:25 00000106: DX terminated
      19:14:25 00000106: Frame Rate=35
      19:14:25 00000106: Debug=0
      19:14:25 00000106: Shutting down application
      19:14:25 00000106: Console destroyed
      Terminating application...
      Freeing music
      Terminating application...
      Freeing sound
      Application terminated

      Ein Baum hat Äste,
      das ist das Beste,
      denn wäre er kahl,
      dann wärs ja ein Pfahl!

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Mithrandir“ ()

      Ich denke, es handelt sich um den Registrierungsbug. Siehe auch hier: Registrierung?
      Die einfachste Lösung dazu ist, die Erweiterung zu installieren. Die entfernt die Registrierungsabfragen auf den Karten.

      Zum Thema Dorfwechsel: Wenn du den Fix mit den drei .dll-Dateien drauf hast, dann kann es daran liegen, dass du die X-Ray Funktionion aktiviert hattest. Das Spiel stürzt ab, wenn du dann oben an den Kartenrand läufst.
      Wo ich bin klappt nichts,...
      aber ich kann ja nicht überall sein.
      Die aktuelle, wenn du den Crash gemacht hast, findest du dort: C:\Users\"Name"\AppData\Local\Virtual Store\"SoAPfad"

      Edit (für angehängte Siege.log):
      "Authorization failed" ist der klassische Reg bug. Vielleicht die Erweiterung in den falschen Pfad installiert. Das Setup hat standardmäßig den Pfad C:/Programme/SiegeofAvalon.

      Wo ich bin klappt nichts,...
      aber ich kann ja nicht überall sein.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „Rucksacksepp“ ()

      Also den Pfad für die Erweiterung hatte ich extra angepasst (sprich Erweiterung direkt in den SoA-Hauptordner installiert, bei mir: C:\Program Files (x86)\Digital Tome\Siege Of Avalon).


      Unter Deinem angegebenen Pfad habe ich leider keine Siege.log, nur: ~GLH0001.TMP, INSTALL.LOG, Siege.INI und UNWISE.INI

      Btw habe ich gerade einen jahrealten Spielstand ausprobiert, der direkt in Krypta1 startet und auch der stürzte ab. Vielleicht liegt es einfach nur an der Map? Vllt. klappt es wenn Du mir die Datei schickst?
      Ab und zu bekomme ich auch folgende Fehlermeldung (meistens aber nicht): Access Violation at adress 0089BCDB in module 'DTMain1.exe'. Write of address 07D34EEB

      ​Ok, STOP! Ich bin ein Idiot. Ich habe den Pfad zwar geändert, war dafür aber zu doof, sodass ein neuer "Siege of Avalon"-Ordner im bestehenden "Siege of Avalon" eingefügt wurde. Deine Erweiterung hat das Problem natürlich beseitigt. (Danke!!) Warum mir das jetzt erst auffällt? KA. Vielen Dank für Deine Hilfe, meistens sitzt das Problem halt doch vor dem Bildschirm... 8|
      Ein Baum hat Äste,
      das ist das Beste,
      denn wäre er kahl,
      dann wärs ja ein Pfahl!

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „Mithrandir“ ()